2017年1月1日日曜日

ubuntu 16.10 に PowerShell をインストールする

https://github.com/PowerShell/PowerShell/blob/master/README.md

Linux でも PowerShell が使えるようになって久しいですが、Ubuntu 向けパッケージは LTS 版の 14.04 と 16.04 用のものしかありません。
で、最新の 16.10 に 16.04 用パッケージをインストールしようとすると、libicu55 の依存関係が解決できないとのエラーメッセージが表示されます。
ubuntu 16.04 では libicu55 だったのが、16.10 では libicu57 にバージョンアップされているのが原因のようです。

そこで、16.04 向けの libicu55 を手動でインストールしてしまいます。apt-get ではインストールできないので、パッケージを以下からダウンロードしてきて、dpkg -i コマンドでインストールします。
http://cz.archive.ubuntu.com/ubuntu/pool/main/i/icu/libicu55_55.1-7_amd64.deb

あとは 16.04 用の PowerShell パッケージをインストールすれば OK。